POP3 のブルートフォース攻撃対策Post Office Protocol (POP) は、メールクライアントがサーバーからメッセージを取得するためのアプリケーション層プロトコルです。 POP1 は 1984 年の RFC 918、POP2 は 1985 年の RFC 937 で定義されました。最新の POP3 は 1988 年の RFC 1081 で導入されました。 POP3 は IMAP とともに、現在も世界中の多くのサーバーで使われています。 このプロトコルは攻撃者やセキュリティ専門家の関心も集めています。POP3 ブルートフォース攻撃のツールは、インターネット上で複数公開されています。 POP3 ポートを公開していると、次のような繰り返しのログエントリが見つかることがあります。 "POP3D" "SENT: +OK POP3" "POP3D" "RECEIVED: CAPA" "POP3D" "SENT: +OK CAPA list follows[nl]USER[nl]UIDL[nl]TOP[nl]." "POP3D" "RECEIVED: USER bob" "POP3D" "SENT: +OK Send your password" "POP3D" "RECEIVED: PASS ***" "POP3D" "SENT: -ERR Invalid user name or password." "POP3D" "RECEIVED: USER alice" "POP3D" "SENT: +OK Send your password" "POP3D" "RECEIVED: PASS ***" "POP3D" "SENT: -ERR Invalid user name or password." "POP3D" "RECEIVED: USER joe" "POP3D" "SENT: +OK Send your password" "POP3D" "RECEIVED: PASS ***" "POP3D" "SENT: -ERR Invalid user name or password." "POP3D" "SENT: +OK POP3" "POP3D" "RECEIVED: CAPA" "POP3D" "SENT: +OK CAPA list follows[nl]USER[nl]UIDL[nl]TOP[nl]." "POP3D" "RECEIVED: USER office" "POP3D" "SENT: +OK Send your password" "POP3D" "RECEIVED: PASS ***" "POP3D" "SENT: -ERR Invalid user name or password." "POP3D" "RECEIVED: USER fax" "POP3D" "SENT: +OK Send your password" "POP3D" "RECEIVED: PASS ***" "POP3D" "SENT: -ERR Invalid user name or password." "POP3D" "RECEIVED: USER reception" "POP3D" "SENT: +OK Send your password" "POP3D" "RECEIVED: PASS ***" "POP3D" "SENT: -ERR Invalid user name or password." これらの失敗は POP3 への攻撃を示す場合があります。攻撃は帯域幅、メモリ、CPU、ディスク容量といったサーバーのリソースを浪費します。 弱いパスワードを使用するユーザーがいる場合、攻撃者にメールボックスへアクセスされるおそれがあります。 RdpGuard は POP3 サーバーをブルートフォース攻撃から保護します。 RdpGuard は、対応するメールログまたは暗号化されていない POP3 トラフィックから失敗を検出します。SSL/TLS にはログ監視を使用してください。 同じ IP からの失敗が設定したしきい値に達すると、攻撃元のアドレスをブロックします。 64 ビット版 Windows / Windows Server 対応。対応 Windows バージョン。 関連情報 | RdpGuard 10.4.5 を無料で試す RdpGuard の保護対象:
お客様の声 "本当に素晴らしいソフトウェアです。サーバーが常に攻撃を受けていたので、安心できるようになりました。RdpGuard、ありがとう。" - Joaquim De Sousa Marques "優れた製品です。以前は TSBlock という他の方が作成したスクリプトで同様の対策をしていましたが、簡素で使い勝手がよくありませんでした。このソフトウェアで作業がずっと楽になりました。小規模企業にとっても購入する価値があります。" - J. Johnson "この製品には感心しました。私たちはダラス北部の教会です。今朝、リモートアクセス用サーバーで多数のログイン失敗を発見しました。友人に勧められて、すぐに体験版をダウンロードしました。数分で 5 件ほどの IP アドレスがブロックされ、それを見て購入を決めました。10 分から 15 分後には約 30 件になり、その少なくとも 3 分の 1 は海外からの侵入の試みでした。素晴らしい製品をありがとうございます。多くの問題を未然に防いでいただいたのかもしれません。" - John Hallford "このソフトウェアが気に入っています。Windows サーバーへの RDP 攻撃が絶えません。ルーターでアクセスを遮断したいところですが、長年のお客様の多くにも影響してしまいます。" - Scott Hirsch "とても気に入っています。VB スクリプトをカスタマイズするより簡単です。" - Nick Brennan "RDP の攻撃者を本当に止めてくれる素晴らしい製品です :-)" - Dave、英国 "まず、とても便利なアプリケーションで、Server 2012 R2 の保護に大変役立っています。RdpGuard は、私が見つけた中で最も優れたソリューションです。10 分間試してから製品版を購入しました。:-)" - Carsten Baltes その他の製品 |