Configure la auditoría de inicios de sesión MS SQL y las exclusiones del evento 18456.
RdpGuard
Prevención de intrusiones para su servidor Windows

Protección de MS SQL Server contra fuerza bruta

Acerca de la protección

RdpGuard protege SQL Server contra intentos de adivinar contraseñas supervisando el registro Application de Windows. Bloquea una IP cuando los inicios de sesión fallidos o los escaneos detectados alcanzan el umbral.

Ejecute RdpGuard en el equipo Windows que aloja SQL Server. Habilite la auditoría de inicios de sesión y elija los eventos que desea supervisar: 18456, 17832 y 17836.

Habilitar la auditoría de inicios de sesión de SQL Server

  1. Abra SQL Server Management Studio y conéctese a su instancia.

  2. En Object Explorer, haga clic con el botón derecho en el servidor y elija Properties.

    Menú contextual del servidor en SQL Server Management Studio, con Properties seleccionado
    Haga clic con el botón derecho en el servidor y elija Properties.
  3. Seleccione Security. En Login auditing, elija Failed logins only o Both failed and successful logins.

    Página Security de las propiedades de SQL Server con las opciones de auditoría
    Elija una opción de auditoría que incluya los inicios de sesión fallidos.
  4. Haga clic en Aceptary reinicie lainstancia de SQL Server para aplicar la auditoría.

    Elija un momento adecuado: el reinicio desconecta las sesiones activas de la base de datos.

Consulte las instrucciones de Microsoft sobre auditoría de inicios de sesión.

Configurar la protección MS SQL Server

  1. Abra el panel de RdpGuard y haga clic en MS-SQL en Protocolos supervisados.

    Botón MS-SQL en los protocolos supervisados de RdpGuard
    Haga clic en MS-SQL para abrir su configuración.
  2. Marque Activar la protección de MS-SQL, elija los eventos que desea supervisar y haga clic en Guardar.

    Configuración MS-SQL: protección habilitada y eventos 18456, 17832 y 17836 seleccionados
    Habilite la protección, elija los eventos y guarde.

Eventos que se supervisarán

Los tres eventos están habilitados de forma predeterminada:

  • 18456 - Inicio de sesión fallido. Manténgalo habilitado para detectar fallos repetidos. Un fallo también puede deberse a un error de escritura o a una aplicación mal configurada.
  • 17832 - Paquete de inicio de sesión no válido. SQL Server no pudo procesar el paquete del cliente. Puede indicar un sondeo o un problema de configuración.
  • 17836 - Longitud de paquete incoherente. La longitud declarada no coincide con los datos recibidos. RdpGuard cuenta estos eventos como escaneos.

Exclusiones del evento ID 18456

Utilice las exclusiones para ignorar fallos legítimos conocidos registrados como 18456. Copie un fragmento distintivo del campo Reason.

  1. En Configuración de MS-SQL, haga clic en Exclusiones... junto aEvento ID 18456.

    Enlace Exclusiones junto al evento 18456 en la configuración MS-SQL
    Haga clic en Exclusiones junto a Evento ID 18456.
  2. Introduzca un patrón por línea y haga clic en Aceptar.

    Exclusiones MS-SQL con un patrón de ejemplo de fallo de acceso a una base de datos
    Utilice el texto de los eventos que desea excluir.
  3. Haga clic en Guardar en Configuración de MS-SQL para aplicar las exclusiones.

La comparación distingue mayúsculas de minúsculas. Los patrones son literales; * y ? no son comodines. Un evento se ignora si un patrón aparece en alguno de sus valores de datos.

Los patrones pueden coincidir con otros campos además de Reason : evite textos cortos o genéricos. Estas exclusiones solo se aplican a 18456, no a 17832 ni a 17836.

Pruebe RdpGuard 10.4.5

RdpGuard protege:

Opiniones de clientes

"Este software es realmente excelente. Es un alivio, porque mi servidor recibe ataques constantemente. Gracias, RdpGuard." - Joaquim De Sousa Marques

"Un buen producto. Usaba una solución similar, rudimentaria y poco práctica, con un script llamado TSBlock (que no es mío). Este software facilita mucho las cosas y merece la pena para una pequeña empresa." - J. Johnson

"Su producto me impresiona. Somos una iglesia del norte de Dallas. Esta mañana descubrí numerosos intentos de inicio de sesión fallidos en nuestro servidor de acceso remoto. Un amigo me recomendó su producto y descargué la prueba de inmediato. En pocos minutos se habían bloqueado unas cinco direcciones IP: eso me bastó para comprarlo. En 10 o 15 minutos, la lista llegó a unas treinta, de las cuales al menos un tercio eran intentos de intrusión internacionales. Gracias por este excelente producto. Quizá nos hayan ahorrado muchos problemas." - John Hallford

"Me encanta este software. Los ataques RDP a nuestros servidores Windows no cesan. Bloquearíamos ese acceso en el router, pero eso perjudicaría a muchos de nuestros clientes de toda la vida." - Scott Hirsch

"¡Me encanta este software! Es más sencillo que personalizar scripts VB." - Nick Brennan

"Un producto excelente que realmente detiene a los atacantes RDP :-)" - Dave, Reino Unido

"Ante todo, su aplicación es muy (!!!) útil y la valoro mucho para proteger mi servidor 2012 R2. RdpGuard es la mejor solución que he encontrado en el mercado. Tras diez minutos de prueba, compré la versión completa. :-)" - Carsten Baltes

Otros productos
Copyright © 2012-2026 Netsdk Software FZE. Todos los derechos reservados. Condiciones de uso (en inglés). Política de privacidad (en inglés).